Requisitos

Para executar WordPress recomendamos que o teu servidor sexa compatible con:

  • PHP versión 7.2 ou superior.
  • MySQL versión 5.6 ou superior Ou MariaDB versión 10.0 ou superior.
  • Compatible con HTTPS

Exactamente. Recomendamos Apache ou Nginx ao ser os máis robustos e flexibles servidores para executar WordPress, pero calquera servidor que sexa compatible con PHP e MySQL funcionará. É dicir, non podemos probar todo entorno posible e cada aloxamento da nosa páxina de aloxamento é compatible co anterior sen problemas.

Nota: Se estás nun ambiente herdado no que só ten versións antiguas de PHP ou MySQL, WordPress tamén funciona con PHP 5.2.4+ e MySQL 5.0+ , pero estas versións chegaron ao final de ciclo de vida oficial e polo tanto podrían exponer o teu sitio a vulnerabilidades de seguridade.

Pregúntao

Aquí tes unha carta que podes enviar ao teu provedor de aloxamento; copia e pega!

Estou interesado en usar o software web de código aberto WordPress de <https://wordpress.org/> e gustaríame saber si a miña conta é compatible co seguinte:

  • PHP 7.2 ou maior
  • MySQL 5.6 ou superior Ou MariaDB 10.0 ou superior
  • Nginx ou Apache con módulo mod_rewrite
  • é compatible con HTTPS

Grazas!

Non obrigatorio, pero sí recomendado para unha mellor seguridade.

O aloxamento é máis seguro cando as aplicacións PHP, como WordPress, se executan empregando un nome de usuario da conta en vez do nome de usuario do servidor compartido. Pregunta ao teu provedor de aloxamento que fan para garantir a seguridade da túa conta.