Redis Object Cache

Descrición

Un backend de caché de obxectos persistente impulsado por Redis®¹. É compatible con Predis, PhpRedis (PECL), Relay, replicación, sentinelas, clustering e WP-CLI.

Para axustar os parámetros de conexión, engadir un prefixo ás claves da caché ou configurar a replicación/clustering, consulta as opcións de configuración.

Object Cache Pro

Un backend de caché de obxectos Redis®¹ de nivel empresarial. Realmente fiable, moi optimizado, totalmente personalizable e cun enxeñeiro dedicado cando máis o necesitas.

  • Reescrito para un rendemento puro
  • 100% compatible coa API de WordPress
  • Serialización e compresión máis rápidas
  • Depuración & rexistro sinxelos
  • Precarga de caché e analítica
  • Probas unitarias completas (100% de cobertura do código)
  • Conexións seguras con TLS
  • Comprobacións de estado mediante WordPress & WP CLI
  • Optimizado para WooCommerce, Jetpack & Yoast SEO

Máis información sobre Object Cache Pro.

¹ Redis é unha marca rexistrada de Redis Ltd. Todos os dereitos sobre ela están reservados a Redis Ltd. Calquera uso por parte de Redis Object Cache é só con fins de referencia e non indica patrocinio, aprobación nin afiliación entre Redis e Redis Object Cache.

Resolución de problemas

Podes atopar respostas ás preguntas habituais e a resolución de erros comúns nas FAQ. Lelas sempre é máis rápido que agardar unha resposta nos foros de soporte.

Configuración

O plugin inclúe un amplo conxunto de opcións de configuración e de exemplos de conexión. Os usuarios avanzados poden consultar Escalado e replicación

Comandos de WP CLI

Redis Object Cache ten varios comandos de WP CLI; para obter máis información, executa wp help redis despois de instalar o plugin.

Capturas

Instalación

Para ver as instrucións de instalación detalladas, le as instrucións de instalación completas.

Comentarios

28 de Setembro de 2026
I had Redis on my "todo" list for quite a while, but was always a bit nervous about it, as it felt like a big undertaking. This plugin made it very easy to use! With minimal setup, it made a massive improvement in page generation times. And I appreciate the advanced configuration options via wp-config to let me customize things without having to bother with filters or hacky workarounds.It has great support as well. Highly recommend giving it a shot!
23 de Setembro de 2026
Excellent caching solution! I work extensively with Nuxt.js and Node.js to process real-time data for over 80,000 football clubs on my platform. Managing that level of data requires serious optimization, and seeing how well this plugin handles object caching is truly impressive. It makes a massive difference in server response times. Highly recommended for any data-heavy project!
19 de Setembro de 2026 1 resposta
The plugin is fine, as long as no errors occur. When a caching error occurs, the plugin will crash your site, and the only way to restore it is to delete a certain file from the WP Plugin directory. Make sure to comment out the die() and wp_die() calls, as the developer is too stubborn to change this ridiculous behaviour.
18 de Agosto de 2026
IT JUST WORKS! So refreshing and our metal is smoking fast now. Thank you and props to the Redis team for making this so easy for a caveman like me. Simply the best! Better than all the rest, better than anyone, anyone I ever met. SIMPLY THE BEST 🎶 🎶
5 de Xuño de 2026 1 resposta
Truly, I would recommend this plug-in. Fast, efficient, and once you make the normal modifications to your WordPress installation, it works like a charm.The only concern is, if you flush your cache, it flushes the whole DB number the WordPress Site is using in Redis, and whatever else was in that DB number is gone too. This means that if you want to have to-site accurate cache flushes, you will need to setup a DB number per WordPress site you are hosting.Author, please see this and make the flush scoped to the site's cache match, not the whole Redis DB number. Yes this isn't a world ending detail… but could be a chance for a good optimization. Thank you again for this plug-in!!
Ler todas as 179 opinións

Colaboradores e desenvolvedores

“Redis Object Cache” é un software de código aberto. As seguintes persoas colaboraron con este plugin.

Colaboradores

“Redis Object Cache” foi traducido a 19 idiomas. Grazas aos desenvolvedores polas súas contribucións.

Traduce “Redis Object Cache” ao teu idioma.

Interesado no desenvolvemento?

Revisa o código, bota unha ollada aorepositorio SVN, ou subscríbete ao log de desenvolvemento por RSS.

Rexistro de cambios

3.0.0

  • Permitir Predis v3.0 como dependencia de Composer
  • Actualizada a biblioteca Predis incluída á v2.4.1
  • Actualizado ApexCharts á v4.7.0
  • Indícase cando a caché está desactivada mediante a constante WP_REDIS_DISABLED
  • Engadida a constante WP_REDIS_CHART_COLOR
  • Engadida a constante WP_REDIS_LOAD_APEXCHARTS
  • Corrixido que wp_cache_replace() escribise claves que non existen e informase mal do seu resultado
  • Corrixido que os métodos de caché en bloque deixasen a conexión bloqueada no modo pipeline
  • Corrixido que as conexións de PhpRedis/Relay ignorasen WP_REDIS_USERNAME
  • Corrixido que WP_REDIS_USERNAME se ignorase cando non hai contrasinal configurado
  • Corrixido o tratamento dos valores baleiros de WP_REDIS_PASSWORD
  • Corrixido o erro nas conexións con fragmentación (sharding) cando se usa WP_REDIS_USERNAME con PhpRedis anterior á v5.3.0
  • Corrixido o nome de usuario que faltaba nos diagnósticos das conexións en clúster

2.8.0

  • Elimínanse os transients cando se activa a caché
  • Mellorados os estilos para WordPress 7.x
  • Respectar WP_REDIS_SSL_CONTEXT cando se usa Predis e conexións en clúster
  • Engadidos aos comandos de WP CLI os ganchos redis_object_cache_(disable|update_dropin) que faltaban
  • Corrixido o parámetro de resultado da acción redis_object_cache_enable

2.7.0

  • Conservar o TTL da clave ao chamar aos métodos (in|de)crement
  • Actualizadas as sinaturas das funcións wp_cache_*() para coincidir co núcleo
  • Eliminado o soporte obsoleto de HHVM
  • Eliminada a constante obsoleta WP_REDIS_SERIALIZER

2.6.5

  • Corrixido un problema cos valores de caché de (in|de)crement cando se usa igbinary

2.6.4

  • Evitados algúns avisos de obsolescencia
  • Corrixido un problema cos valores de caché de (in|de)crement

2.6.3

  • Cambiado a E_USER_DEPRECATED en lugar de _doing_it_wrong() no drop-in
  • Corrixido o erro ao usar Credis (obsoleto) como cliente

2.6.2

  • Corrixidos máis erros de análise de heredoc en PHP 7.2

2.6.1

  • Corrixido o erro de análise de heredoc en PHP 7.2
  • Corrixida a chamada á función non definida wp_rand()

2.6.0

  • Engadida a cabeceira Primary Branch
  • Engadido id ás etiquetas de script/style
  • Actualizado Predis á v2.4.0
  • Actualizado Credis á v1.17.0
  • Marcado como probado ata a 6.8
  • Cumprir con Plugin Check (PCP)
  • Corrixido que (in|de)crement non funcionase co serializador
  • Corrixido un problema pouco habitual do modo de replicación
  • Corrixido un erro fatal pouco habitual nos diagnósticos

2.5.4

  • Respectar WP_REDIS_SCHEME nas conexións Cluster
  • Corrixido un problema con Predis e a conexión SentinelReplication
  • Corrixida a barra dobre na URL de admin.css

2.5.3

  • Engadida a constante WP_REDIS_DISABLE_GROUP_FLUSH
  • Engadidos o filtro redis_cache_manager_capability e a constante WP_REDIS_MANAGER_CAPABILITY
  • Engadido o soporte de WP_REDIS_SSL_CONTEXT para as conexións en clúster de PhpRedis
  • Corrixidos varios problemas con Predis e as conexións en clúster/replicadas
  • Corrixido outro erro fatal pouco habitual en show_error_and_die()

2.5.2

  • Respectar WP_REDIS_FLUSH_TIMEOUT nos scripts Lua de baleirado
  • Mellorado o soporte de DISALLOW_FILE_MODS
  • Revertido o cambio de comportamento de sanitize_key_part()
  • Corrixido un erro fatal pouco habitual en show_error_and_die() (de novo)

2.5.1

  • Engadidos tempos límite aos diagnósticos
  • Dar soporte a instalacións de PHP pouco habituais sen a extensión sockets
  • Corrixido un erro fatal pouco habitual en show_error_and_die()
  • Corrixida a advertencia do aviso de obsolescencia en sanitize_key_part()

2.5.0

  • Require WordPress 4.6 ou posterior
  • Cargar o text-domain só cando sexa necesario
  • Engadida a constante WP_REDIS_DISABLE_DROPIN_CHECK
  • Respectar o filtro file_mod_allowed e a constante DISALLOW_FILE_MODS
  • Renomeado o arquivo de proba .redis-write-test.tmp a object-cache.tmp
  • Chamar á acción redis_object_cache_error antes de wp_die()
  • Permitir definir WP_REDIS_PLUGIN_PATH noutro lugar
  • Engadido un tempo límite de baleirado experimental (por defecto é de 5 segundos)
  • Eliminados os grupos ignorados por defecto que non eran necesarios

2.4.4

  • Mellorado o tratamento de resultados de transacción inesperados

2.4.3

  • Corrixido o erro de sintaxe en PHP <=7.2
  • Corrixida a carga das traducións da páxina de erro

2.4.2

  • Feito máis robusto o script da barra de administración
  • Melloradas as instrucións de recuperación en redis-error.php
  • Mellorada a detección de CloudLinux
  • Melloras de localización
  • Evitar que W3 Total Cache e LiteSpeed Cache sobrescriban o drop-in
  • Corrixido o soporte do nome de usuario ACL cando se usa Predis e a sintaxe de array

2.4.1

  • Corrixido o erro de sintaxe en PHP <=7.2

2.4.0

  • Baleirar a caché ao alternar a caché de obxectos
  • Mostrar unha mensaxe de erro personalizada cando Redis non é accesible
  • Non permitir activar a caché de obxectos cando Redis non é accesible
  • Marcada como obsoleta a constante de configuración arriscada WP_REDIS_SERIALIZER; usa WP_REDIS_IGBINARY no seu lugar
  • Dar soporte a WP_REDIS_USERNAME cando se usa Predis
  • Mostrar os decimais da taxa de acertos da caché no nodo da barra de administración
  • Ocultar os segredos ao mostrar WP_REDIS_SERVERS
  • Mellorada a compatibilidade con Accelerate WP de CloudLinux
  • O baleirado da caché desde a barra de administración agora usa AJAX

2.3.0

  • Mostrar o widget do Escritorio só aos administradores
  • Engadido un nodo á barra de administración (desactívao con WP_REDIS_DISABLE_ADMINBAR)
  • Engadida a constante de configuración WP_REDIS_SSL_CONTEXT
  • Lanzar erros cando se produce un erro de conexión
  • Engadido o soporte de nomes de usuario cando se usa Predis
  • Engadido o soporte para cargar Predis desde WP_REDIS_PLUGIN_PATH
  • Feitas máis estritas as conexións de socket unix de Predis
  • Corrixido un fallo pouco habitual ao baleirar grupos
  • Corrixido o ping do clúster cando se usa Predis
  • Actualizado Predis á v2.1.2
  • Mellorada a documentación

2.2.4

  • Rexistrar tarde o comando de CLI wp redis
  • Non competir con Object Cache Pro polo comando wp redis
  • Evitar que Perflab sobrescriba o drop-in da caché de obxectos
  • Actualizado Predis á v2.1.1
  • Evitar un erro de tipo cando falla a transacción
  • Comprobar as cabeceiras de tipo de contido incompatibles

2.2.3

  • Engadido o soporte de wp_cache_flush_group()
  • Actualizado Credis á v1.14.0
  • Eliminado o parámetro $delay de wp_cache_flush()
  • Evitado un erro pouco habitual nos diagnósticos ao ler os erros de conexión

2.2.2

  • Usar QM_Data_Cache en lugar de QM_Data
  • Corrixida a advertencia de nome non composto na instrución use de WP_Error

2.2.1

  • Engadida a función wp_cache_supports() de WordPress 6.1
  • Actualizado Predis á v2.0.3
  • Evitar chamadas tempranas a microtime() en WP_Object_Cache::get()
  • Dar soporte á nova clase QM_Data de Query Monitor
  • Lanzar unha excepción se o pipeline devolve resultados inesperados

2.2.0

  • Engadido o filtro redis_cache_add_non_persistent_groups
  • Corrixidos os parámetros de wp_add_dashboard_widget
  • Corrixido o problema de replicación de WP_REDIS_SERVERS con Predis v2.0
  • Corrixido o soporte da cadea WP_REDIS_CLUSTER
  • Corrixido o problema cando MGET falla na chamada a get_multiple()
  • Corrixidas varias advertencias en caso de fallos do pipeline

2.1.6

  • Corrixidas as discrepancias de SVN

2.1.5

  • Corrixida a chamada a is_predis()

2.1.4

  • Engadido o asistente is_predis()

2.1.3

  • Corrixido un fallo en wp_cache_add_multiple() e wp_cache_set_multiple()

2.1.2

  • Corrixida e mellorada a lóxica de wp_cache_*_multiple()
  • Chamar á acción redis_object_cache_set en wp_cache_set_multiple()
  • Chamar á acción redis_object_cache_delete en wp_cache_delete_multiple()
  • Comprobar se o nome de grupo sen procesar se ignora, non o nome sanitizado
  • Eliminado o rastrexo

2.1.1

  • Elevado o requisito de PHP a 7.2
  • Renomeado WP_REDIS_DIR a WP_REDIS_PLUGIN_DIR
  • Corrixido un erro fatal pouco habitual nos diagnósticos
  • Permitir instalacións de Predis v1.1 con Composer
  • Dar soporte ao uso da cadea WP_REDIS_CLUSTER

2.1.0

  • Elevado o requisito de PHP a 7.0
  • Marcados como obsoletos os clientes Credis e HHVM
  • Actualizado Predis á v2.0.0
  • Actualizado Credis á v1.13.1
  • Mellorada a lexibilidade dos clústeres nos diagnósticos
  • Mellorada a conexión aos clústeres
  • Corrixido o ping aos clústeres despois de conectar
  • Corrixidos varios fallos en connect_using_credis()

2.0.26

  • Corrixido un fallo en wp_cache_delete_multiple() cando se usa Predis
  • Corrixido un fallo en wp_cache_add_multiple() cando a adición á caché está suspendida

2.0.25

  • Eliminada a función defectuosa wp_cache_add_multiple()

2.0.24

  • Mellorar o formato das etiquetas/información emerxente das métricas
  • Corrixido que o gráfico de métricas non se renderizase
  • Actualizado Predis á v1.1.10
  • Actualizado Credis á v1.13.0
  • Dar soporte a composer/installers v1 e v2
  • Ligazón á páxina de axustes cando se atopou un drop-in alleo
  • Engadida a función wp_cache_flush_runtime()
  • Engadida a función wp_cache_add_multiple()
  • Engadida a función wp_cache_delete_multiple()

2.0.23

  • Engadido o soporte para Relay
  • Pequenas correccións e melloras de UX
  • Corrixido o aviso de obsolescencia de PHP 8.1
  • Actualizado ApexCharts á v3.31.0

2.0.22

  • Correccións de compatibilidade con PHP 8.1
  • Actualizado a Predis v1.1.9
  • Engadida unha ligazón aos axustes no widget
  • Renovado o panel de diagnósticos
  • Actualizado ApexCharts á v3.30.0
  • Redirixir aos axustes do plugin despois da activación
  • Corrixida a ruta incorrecta ao arquivo diagnostics.php
  • Corrixido o desbordamento do gráfico na pestana de axustes
  • Corrixido o ping do clúster de Predis
  • Evitar unha advertencia cando o cartafol de contido non é escribible

2.0.21

  • Engadidos diagnósticos de métricas
  • Engadido o alias WP_Object_Cache::decr()
  • Movido o arquivo diagnostics.php

2.0.20

  • Corrixida a versión de wp.org

2.0.19

  • Facer único o identificador da métrica
  • Establecer un prefixo único para os sitios aloxados en Cloudways
  • Non imprimir o comentario HTML de depuración cando WP_CLI é true

2.0.18

  • Engadidos a acción redis_object_cache_trace e a constante WP_REDIS_TRACE
  • Actualizado ApexCharts á v3.26.0
  • Corrixido un problema con WP_REDIS_DISABLE_METRICS

2.0.17

  • Limpeza de código
  • Corrixidas as métricas que faltaban
  • Corrixida a proba do sistema de arquivos

2.0.16

  • Actualizado Credis á v1.11.4
  • Corrixidos os estilos do aviso do drop-in
  • Movidas as métricas a unha clase propia
  • Engadido o filtro redis_cache_validate_dropin
  • Usar a constante WP_DEBUG_DISPLAY (en vez de WP_DEBUG) para mostrar a información de depuración
  • Corrixido un erro pouco habitual en wp_cache_get_multiple()
  • Eliminado o uso de intval()

2.0.15

  • Revertidos os cambios de build_key() debido a problemas en contornos multisitio

2.0.14

  • Feita traducible a tarxeta de Object Cache Pro
  • Engadido WP_REDIS_SERIALIZER aos diagnósticos
  • Mellorada a velocidade de build_key()
  • Dar soporte a definir WP_REDIS_PREFIX e WP_REDIS_SELECTIVE_FLUSH mediante variable de contorno
  • Engadido WP_REDIS_METRICS_MAX_TIME para axustar o intervalo de tempo das métricas almacenadas
  • Atrasar a carga do text domain e a programación ata o gancho init
  • Actualizada a biblioteca Predis incluída á v1.1.6
  • Evitado un problema de referencia de variables en connect_using_credis()

2.0.13

  • Actualizada a biblioteca Predis incluída á v1.1.4
  • Feito de redis-cache un grupo global para mellorar as métricas en multisitio
  • Cambiado á sintaxe curta de arrays
  • Engadidas as etiquetas @since a todos os ganchos
  • Usar parse_url() en lugar de wp_parse_url() no drop-in
  • Corrixido o nome da variable da instancia do plugin en wp redis status

2.0.12

  • Corrixido o cálculo das métricas de bytes
  • Corrixido un problema coas configuracións de Predis non estándar
  • Mellorados os estándares de codificación de WordPress

2.0.11

  • Corrixido un problema en wp_cache_get_multiple() cando se usa Predis
  • Evitado o aviso de índice non definido nos diagnósticos

2.0.10

  • Corrixida a deserialización de valores en wp_cache_get_multiple()

2.0.9

  • Resaltar o tipo de métrica actual usando a cor
  • Mostrar a pestana «Métricas» cando as métricas están desactivadas
  • Refactorizada a lóxica da conexión e do estado de Redis
  • Actualizado Predis á v1.1.2
  • Eliminado o aviso de obsolescencia de Predis
  • Corrixida a obtención de claves derivadas en wp_cache_get_multiple()

2.0.8

  • Corrixido que as pestanas non funcionasen en 2.0.6 e 2.0.7 debido a un problema do SVN de WP.org

2.0.7

  • Corrixido un problema con wp_cache_get_multiple()

2.0.6

  • Engadida aos diagnósticos unha proba experimental do sistema de arquivos
  • Refactorizada a lóxica da pestana de axustes (tamén se corrixeu o salto)
  • Corrixidos problemas con wp_cache_get_multiple()
  • Devolver un booleano desde wp_cache_delete()
  • Usar redis-cache como espazo de nome dos eventos JS
  • Ocultar a liña Pro no widget cando os banners están desactivados
  • Renomeada a acción redis_object_cache_get_multi a redis_object_cache_get_multiple

2.0.5

A versión 2.0 é unha reescritura significativa do plugin. Le as notas da versión v2.0.0.

  • Corrixido que os botóns de acción de multisitio non funcionasen
  • Eliminada a advertencia obsoleta sobre PHP 5.4
  • Engadido o soporte de read_timeout a Credis
  • Mostrar os parámetros de conexión cando se usa Credis
  • Engadida unha ligazón á wiki no aviso de actualización de Predis

2.0.4

  • Tentar actualizar de forma fiable o dropin cando está obsoleto
  • Mostrar o nome de usuario ACL na pantalla de axustes
  • Mostrar os diagnósticos completos con wp redis status
  • Establecer sempre FS_CHMOD_FILE ao copiar o object-cache.php
  • Non codificar os puntos dos contrasinais nos diagnósticos
  • Chamar a redis_object_cache_update_dropin durante a actualización do dropin

2.0.3

  • Ocultar a pestana «Métricas» cando as métricas están desactivadas
  • Corrixido que admin.js non se cargase en contornos multisitio
  • Evitar un erro fatal ao interactuar coas métricas cando Redis deixou de estar dispoñible
  • Engadido WP_Object_Cache::__get() para compatibilidade con versións anteriores

2.0.2

  • Actualizados o arquivo POT e os comentarios para tradutores

2.0.1

  • Dar soporte a versións máis antigas de Query Monitor
  • Feito máis útil o estado de «Dropin»
  • Ocultar a versión de Redis nos axustes cando non está dispoñible
  • Reducidas as rutas das dependencias usando o paquete composer-custom-directory-installer
  • Evitar conflitos de QM_Collector con outros plugins
  • Evitar problemas coas métricas cando a caché non está dispoñible
  • Corrixida a ligazón «Axustes» na lista de plugins
  • Corrixida a lóxica de WP_REDIS_DISABLED

2.0.0

A versión 2.0 é unha reescritura significativa. Agora o plugin require PHP 5.6, igual que WordPress 5.2.

O repositorio de GitHub e Composer moveuse de tillkruss/redis-cache a rhubarbgroup/redis-cache.

Nas redes multisitio, asegúrate de «Activar na rede» o plugin despois de actualizar á v2.x.

  • Require PHP 5.6
  • Agora o plugin é «só para a rede»
  • Cambiado a WPCS para os estándares de código
  • Renovada a pantalla de axustes
  • Engadidas métricas da caché de obxectos (no widget do escritorio e nos axustes)
  • Engadido o soporte para Query Monitor
  • Engadido o espazo de nome Rhubarb\RedisCache a todos os arquivos
  • Engadido o soporte da nova función wp_cache_get_multi() de WP 5.5
  • Engadida a función redis_object_cache() para recuperar a instancia do plugin
  • Engadidos avisos do dropin ao escritorio da rede
  • Engadido o soporte para establecer os números de base de datos de Sentinel
  • Dar soporte á identificación con nome de usuario e contrasinal ACL de Redis 6
  • Dar soporte a sobrescribir o dropin existente na pantalla de axustes
  • Usar o padrón singleton para instanciar o plugin
  • Usar Composer para instalar e cargar Predis
  • Actualizar o dropin da caché de obxectos durante a actualización do plugin
  • Usar métodos separados para conectar con todos os clientes
  • Eliminadas as rarezas de CUSTOM_USER_TABLE e CUSTOM_USER_META_TABLE
  • Engadido themes como grupo ignorado
  • Cambiado a 1 segundo o tempo límite por defecto de conexión e lectura
  • Evitada a condición de carreira en add_or_replace()
  • Renomeado WP_CACHE_KEY_SALT a WP_REDIS_PREFIX para maior claridade
  • Substituída a terminoloxía «slave» por «replica»
  • Só facer SELECT da base de datos cando non sexa 0

1.6.1

  • Corrixido un problema co comentario do pé de páxina que aparecía durante as solicitudes AJAX

1.6.0

  • Mellorada a sanitización dos nomes de grupo (grazas @naxvog)
  • Evitado un erro fatal ao substituír un dropin alleo
  • Engadido un comentario HTML no pé de páxina con información de depuración opcional
  • Eliminadas as suxestións de prefixo

O comentario HTML do pé de páxina só imprime información de depuración cando WP_DEBUG está activado. Para desactivar o comentario por completo, establece a constante WP_REDIS_DISABLE_COMMENT a true.

1.5.9

  • Corrixida a asignación que faltaba da variable $info no construtor
  • Corrixida a condición da advertencia de MaxTTL
  • Cambiado a usar os estilos de botón por defecto

1.5.8

  • Engadida unha mensaxe de advertencia sobre un MaxTTL non válido
  • Engadida unha advertencia sobre a biblioteca Predis sen mantemento
  • Engadida unha suxestión sobre prefixos máis curtos e lexibles
  • Engadida aos axustes a compatibilidade con Redis Cache Pro
  • Corrixido o baleirado da caché cando o prefixo contén caracteres especiais
  • Corrixida a chamada a Redis INFO cando se usan clústeres
  • Limpados un pouco os axustes

1.5.7

  • Engadido o soporte das conexións TLS de PhpRedis
  • Engadido o soporte de tempo límite, tempo límite de lectura e contrasinal cando se usa o clúster de PhpRedis
  • Corrixido un problema co comando INFO
  • Corrixida a clonación de obxectos ao establecer claves de caché

1.5.6

  • Engadida a clonación de obxectos á caché en memoria
  • Corrixido o aviso de PHP relacionado co parámetro read_timeout

1.5.5

Baleira a caché de obxectos despois de actualizar o drop á v1.5.5 para evitar que claves mortas ocupen a memoria de Redis.

  • Eliminada a conversión das claves a minúsculas
  • Eliminado o evento programado de métricas
  • Corrixida a chamada á versión de Redis cando se usa replicación

1.5.4

  • Eliminadas as métricas

1.5.3

  • Corrixido: chamada á función non definida get_plugin_data()
  • Corrixido: chamada ao método non definido WP_Object_Cache::redis_version()

1.5.2

  • Engadida a versión de Redis aos diagnósticos
  • Engadida a constante WP_REDIS_DISABLE_BANNERS para desactivar as promocións
  • Corrixido un problema con redis.replicate_commands()

1.5.1

Este plugin cumpre hoxe (14 de novembro) 5 anos e é apropiado lanzar tamén hoxe a edición empresarial.
Object Cache Pro é unha reescritura realmente fiable, moi optimizada e fácil de depurar deste plugin para pemes.

  • Engadidos os tempos de execución ás accións
  • Engadida a constante WP_REDIS_VERSION
  • Corrixida a compatibilidade con PhpRedis v3
  • Corrixido un problema co baleirado selectivo
  • Corrixido un problema coa inexistencia das funcións mb_*
  • Substituída a tarxeta de Email Address Encoder pola de Redis Cache Pro
  • Recompilar métricas de versións para tomar mellores decisións

1.5.0

Como Predis xa non ten mantemento, recoméndase encarecidamente cambiar a PhpRedis (a extensión PECL de Redis).

  • Mellorado o construtor de nomes de clave de Redis
  • Engadido o soporte dos serializadores de PhpRedis
  • Engadida a acción redis_object_cache_error
  • Engadida a configuración de tempo límite, tempo límite de lectura e reintentos
  • Engadidos grupos que non se poden baleirar (por defecto é ['userlogins'])
  • Corrixido que os contrasinais non aparecesen na lista de servidores

1.4.3

  • Require PHP 5.4 ou posterior
  • Usar formato lexible nos diagnósticos
  • Lanzar unha excepción se falta a biblioteca de Redis
  • Corrixido que a caché non se baleirase para algúns usuarios
  • Corrixidos problemas de administración cando WP_REDIS_DISABLED é false

1.4.2

  • Engadidos fallos de Redis controlados e a constante WP_REDIS_GRACEFUL
  • Mellorado o soporte de clústeres
  • Engadido o filtro redis_cache_expiration
  • Renomeado o filtro redis_object_cache_get a redis_object_cache_get_value

1.4.1

  • Corrixido un posible erro fatal relacionado con wp_suspend_cache_addition()

1.4.0

  • Engadido o soporte de igbinary
  • Engadido o soporte de wp_suspend_cache_addition()

1.3.9

  • Corrixido que WP_REDIS_SHARDS non aparecese na lista de servidores
  • Corrixido que WP_REDIS_SHARDS non funcionase cando se usa a extensión PECL
  • Eliminados os restos de WP_REDIS_SCHEME e WP_REDIS_PATH

1.3.8

  • Cambiado da versión de Predis dun só arquivo á biblioteca completa

1.3.7

  • Volver á versión de Predis dun só arquivo

1.3.6

  • Engadido o soporte de Redis Sentinel
  • Engadido o soporte de sharding
  • Cambiado á versión PHAR de Predis
  • Mellorados os diagnósticos
  • Engadido WP_REDIS_SELECTIVE_FLUSH
  • Engadido o parámetro $fail_gracefully a WP_Object_Cache::__construct()
  • Aplicar sempre WP_REDIS_MAXTTL
  • Pasar $selective e $salt á acción redis_object_cache_flush
  • Non establecer a constante WP_CACHE_KEY_SALT

1.3.5

  • Engadidos diagnósticos básicos á interface de administración
  • Engadida a constante WP_REDIS_DISABLED para desactivar a caché en tempo de execución
  • Evitar o erro «Cabeceira do plugin non válida»
  • Devolver un enteiro desde os métodos increment() e decrement()
  • Evitar que a caché de obxectos se instancie máis dunha vez
  • Separar sempre con punto e coma o prefix e o group da clave de caché
  • Mellorado o rendemento de build_key()
  • Aplicar o filtro redis_object_cache_get só se se rexistraron callbacks
  • Corrixido add_or_replace() para que só estableza a clave de caché se non existe
  • Engadida a acción redis_object_cache_flush
  • Engadida a acción redis_object_cache_enable
  • Engadida a acción redis_object_cache_disable
  • Engadida a acción redis_object_cache_update_dropin

1.3.4

  • Engadido o soporte de WP-CLI
  • Mostrar o host e o porto a non ser que o esquema sexa unix
  • Actualizados os grupos globais e ignorados por defecto
  • Baleirar a caché ao activar, desactivar e desinstalar

1.3.3

  • Actualizado Predis a v1.1.1
  • Engadido o método redis_instance()
  • Engadido o alias de método incr() para compatibilidade con Batcache
  • Engadidas as constantes WP_REDIS_GLOBAL_GROUPS e WP_REDIS_IGNORED_GROUPS
  • Engadida a acción redis_object_cache_delete
  • Usar WP_PLUGIN_DIR con WP_CONTENT_DIR como alternativa
  • Establecer o contrasinal cando se usa un clúster ou replicación
  • Mostrar o cliente de Redis en stats()
  • Cambiada a visibilidade de $cache a pública
  • Usar a sintaxe antiga de arrays, por se acaso

1.3.2

  • Asegurar que $result non é false en WP_Object_Cache::get()

1.3.1

  • Corrixido un problema de conexión

1.3

  • Nova interface de administración
  • Engadido o soporte dos parámetros $force e $found de wp_cache_get()
  • Engadido o soporte de clustering e replicación con Predis

1.2.3

  • Melloras da IU

1.2.2

  • Engadida a acción redis_object_cache_set
  • Engadidos a acción e o filtro redis_object_cache_get
  • Evitadas as mensaxes de estado duplicadas na administración
  • Cargar a biblioteca Predis incluída só se é necesario
  • Cargar a biblioteca Predis incluída usando a constante WP_CONTENT_DIR
  • Actualizada a saída do método stats() para que sexa uniforme con WordPress

1.2.1

  • Engadido composer.json
  • Engadidos ganchos de desactivación e desinstalación para eliminar object-cache.php
  • Engadidas funcións de serialización locais para mellorar o soporte de advanced-cache.php
  • Actualizada a versión de Predis incluída a 1.0.3
  • Actualizada a estrutura dos títulos para que sexa semántica

1.2

  • Engadido o soporte de multisitio
  • Movido o menú de administración ao menú Axustes
  • Corrixido o aviso de PHP en get_redis_client_name()

1.1.1

  • Chamar a select() e, opcionalmente, a auth() se se usa a extensión de HHVM

1.1

  • Engadido o soporte da extensión de Redis de HHVM
  • Engadido o soporte da extensión PECL de Redis
  • Engadida a constante WP_REDIS_CLIENT, para establecer o cliente de Redis preferido
  • Engadida a constante WP_REDIS_MAXTTL, para forzar a caducidade das claves de caché
  • Mellorados os métodos add_or_replace(), get(), set() e delete()
  • Mellorados os estilos da pantalla de administración
  • Eliminada toda a internacionalización/localización do drop-in

1.0.2

  • Engadido o botón «Baleirar caché»
  • Engadido o soporte de sockets de dominio UNIX
  • Mellorado significativamente o rendemento da recuperación de obxectos da caché
  • Actualizada a biblioteca Predis incluída á versión 1.0.1

1.0.1

  • Cargar as traducións do plugin
  • Ocultar os avisos globais de administración aos usuarios que non son administradores
  • Evitar o acceso directo aos arquivos redis-cache.php e admin-page.php
  • Coloreado o botón «Desactivar a caché de obxectos»
  • Chamar a Predis\Client->connect() para evitar unha posible Predis\Connection\ConnectionException sen capturar

1.0

  • Versión inicial